Примеры схем – Однолинейная электрическая схема электроснабжения примеры однолинейных схем примеры электрических схем

Содержание

Схемы электрические. Типы схем / Habr

Привет Хабр!
Чаще в статьях приводят вместо электрических схем красочные картинки, из-за этого возникают споры в комментариях.
В связи с этим, решил написать небольшую статью-ликбез по типам электрических схем, классифицируемых в Единой системе конструкторской документации (ЕСКД).

На протяжении всей статьи буду опираться на ЕСКД.
Рассмотрим ГОСТ 2.701-2008 Единая система конструкторской документации (ЕСКД). Схемы. Виды и типы. Общие требования к выполнению.
Данный ГОСТ вводит понятия:

  • вид схемы — классификационная группировка схем, выделяемая по признакам принципа действия, состава изделия и связей между его составными частями;
  • тип схемы — классификационная группировка, выделяемая по признаку их основного назначения.

Сразу договоримся, что вид схем у нас будет единственный — схема электрическая (Э).
Разберемся какие типы схем описаны в данном ГОСТе.

Далее рассмотрим каждый тип схем более подробно применительно для электрических схем.
Основной документ:
ГОСТ 2.702-2011 Единая система конструкторской документации (ЕСКД). Правила выполнения электрических схем
.
Так, что же такое и с чем «едят» эти схемы электрические?
Нам даст ответ ГОСТ 2.702-2011: Схема электрическая — документ, содержащий в виде условных изображений или обозначений составные части изделия, действующие при помощи электрической энергии, и их взаимосвязи.

Схемы электрические в зависимости от основного назначения подразделяют на следующие типы:


Схема электрическая структурная (Э1)

На структурной схеме изображают все основные функциональные части изделия (элементы, устройства и функциональные группы) и основные взаимосвязи между ними. Графическое построение схемы должно обеспечивать наилучшее представление о последовательности взаимодействия функциональных частей в изделии. На линиях взаимосвязей рекомендуется стрелками обозначать направление хода процессов, происходящих в изделии.
Пример схемы электрической структурной:

Схема электрическая функциональная (Э2)

На функциональной схеме изображают функциональные части изделия (элементы, устройства и функциональные группы), участвующие в процессе, иллюстрируемом схемой, и связи между этими частями. Графическое построение схемы должно давать наиболее наглядное представление о последовательности процессов, иллюстрируемых схемой.
Пример схемы электрической функциональной:

Схема электрическая принципиальная (полная) (Э3)

На принципиальной схеме изображают все электрические элементы или устройства, необходимые для осуществления и контроля в изделии установленных электрических процессов, все электрические взаимосвязи между ними, а также электрические элементы (соединители, зажимы и т.д.), которыми заканчиваются входные и выходные цепи. На схеме допускается изображать соединительные и монтажные элементы, устанавливаемые в изделии по конструктивным соображениям. Схемы выполняют для изделий, находящихся в отключенном положении.
Пример схемы электрической принципиальной:

Схема электрическая соединений (монтажная) (Э4)

На схеме соединений следует изображать все устройства и элементы, входящие в состав изделия, их входные и выходные элементы (соединители, платы, зажимы и т.д.), а также соединения между этими устройствами и элементами. Расположение графических обозначений устройств и элементов на схеме должно примерно соответствовать действительному размещению элементов и устройств в изделии. Расположение изображений входных и выходных элементов или выводов внутри графических обозначений и устройств или элементов должно примерно соответствовать их действительному размещению в устройстве или элементе.
Пример схемы электрической соединений:


Схема электрическая подключения (Э5)

На схеме подключения должны быть изображены изделие, его входные и выходные элементы (соединители, зажимы и т.д.) и подводимые к ним концы проводов и кабелей (многожильных проводов, электрических шнуров) внешнего монтажа, около которых помещают данные о подключении изделия (характеристики внешних цепей и (или) адреса). Размещение изображений входных и выходных элементов внутри графического обозначения изделия должно примерно соответствовать их действительному размещению в изделии. На схеме следует указывать позиционные обозначения входных и выходных элементов, присвоенные им на принципиальной схеме изделия.
Пример схемы электрической подключений:

Схема электрическая общая (Э6)

На общей схеме изображают устройства и элементы, входящие в комплекс, а также провода, жгуты и кабели (многожильные провода, электрические шнуры), соединяющие эти устройства и элементы. Расположение графических обозначений устройств и элементов на схеме должно примерно соответствовать действительному размещению элементов и устройств в изделии.
Пример схемы электрической общей:

Схема электрическая расположения (Э7)

На схеме расположения изображают составные части изделия, а при необходимости связи между ними — конструкцию, помещение или местность, на которых эти составные части будут расположены.
Пример схемы электрической расположения:

Схема электрическая объединенная (Э0)

На данном виде схем изображают различные типы, которые объединяются между собой на одном чертеже.
Пример схемы электрической объединенной:
PS

Это моя первая статья на Хабре не судите строго.

habr.com

назначение и устройство, виды, пример описания

Скачать принципиальную электрическую схемуВажнейшим документом, описывающим работу того или иного оборудования, является принципиальная электрическая схема. Составляется она ещё на стадии проектирования, а уже позже на её базе собирается устройство или система. Выполняется эта схема согласно установленным стандартам в виде чертежа. Понимая, что и как изображено на ней, несложно разобраться в принципе работы конструкции и провести в случае необходимости ремонт или модернизацию.

Понятие и назначение

Для стандартизации и универсальности обозначений, различных радиоэлементов и электрических приборов был введён стандарт их изображения на схемах, что позволило довольно чётко различать узлы. Благодаря этому стало возможным не только подписывать их буквенно, но и графически.

В стандартизованных правилах указывается, что схема — это графически выполненный документ, на котором с помощью условных обозначений и графических изображений представляются части изделия и связи между ними. В зависимости от вида элементов, входящих в состав изображаемого изделия, схемы разделяются на следующие виды: электрические, гидравлические, кинематические и пневматические.

В свою очередь, их также принято разделять по назначению. Они могут быть:

  1. Структурными — изображаются в виде блок-схемы с указанием ключевых узлов с условно выполненными соединениями.
  2. Монтажными (печатны) — на них указывается точное место расположения деталей с разводкой их правильного соединения. Применительно к электросетям, например, проводка в доме, изображаются все комнаты, в которых показываются электрические точки, как к ним подводится электрокабель.
  3. Принципиальные — на них условно указываются все детали, контакты и электрические связи.
  4. Объединённые — содержат на одном листе, как правило, принципиальную и монтажную электрические схемы.

Следует отметить, что при проектировании изделия или электрической системы вначале создаётся блок-схема, затем принципиальная, а уже на основании её и монтажная. Но в радиолюбительстве для понимания работы устройства часто всё происходит наоборот.

Схема — это графически выполненный документ

Таким образом, совокупность изображений электрических деталей и приборов на одном документе с указанием их расположения относительно друг друга называют электрической схемой. Принципиальная же схема определяет полный состав электрических элементов и соединений, входящих в конструкцию какого-либо изделия.

Разработанные чертежи со схемой предназначены для изучения принципа работы устройства или электрической системы. Они часто используются при проведении профилактических и ремонтных работ. Умение читать и составлять план значительно упрощает объяснение и назначение используемого элемента в работе какого-либо прибора.

Стандарт обозначений

Скачать принципиальную электрическую схемуДля упорядоченности обозначений был введён ряд межгосударственных отраслевых стандартов (ГОСТ). Ранее на территории бывшего СССР они носили название государственных. Но после распада и образования Содружества независимых государств были переименованы с сохранением аббревиатуры. Так, основополагающим стандартом считается ГОСТ 2.702-2011 «Единая система конструкторской документации (ЕСКД). Правила выполнения электрических схем». Распространяется он на все электрические схемы существующих и разрабатываемых изделий, а также различных энергетических конструкций. Базируется на следующих ГОСТ:

Принципиальные электрические схемы

В этой документации исчерпывающе указываются виды изделий и стадии разработки. Отдельно рассмотрены основные положения при выполнении электрических схем (ГОСТ 2.702-75 ЕСКД) и условно графические, а также буквенные обозначения на них (ГОСТ 2.710-81, ГОСТ 2.709-89, ГОСТ 2.721-74).

Так, в ГОСТ 2.701-2008 даны определения часто используемым терминам:

  • линия связи – отрезок, соединяющий части цепи или условно изображённую с ней деталь и обозначающий электрическую связь;
  • позиционное обозначение – обязательное присвоение каждой детали или узлу информации, содержащей порядковый номер, наименование и параметр его характеризующий;
  • установка – условное название объекта в энергетических конструкциях;
  • устройство – соединение деталей и связей, образующих конструкцию;
  • функциональная группа – объединение деталей определённого назначения;
  • функциональная цепь – совокупность элементов или функциональных групп, объединённых линиями связей и образующих канал или тракт для реализации определённой цели;
  • элемент – неотъемлемая часть схемы, выполняющая определённую функцию в конструкции, которая не может быть разделена на части, характеризующаяся собственным назначением и уникальным обозначением.

При этом указано, что схема электрическая – это документ, в котором содержатся условные изображения и обозначения составных частей изделия, работающих при помощи электрической энергии и обоюдной взаимосвязи. Причём эти планы могут выполняться как в бумажном виде, так и электронном.

Требования к составлению схем

Суть построения принципиального плана заключается в наглядности понятия процессов, происходящих в изделии. Поэтому главным требованием, предъявляемым к нему, является максимально удобное чтение изображения. Достигается это соблюдением следующих рекомендаций:

  1. Чтение электрических схемВесь план разбивается на определённые функциональные группы, состав которых определяется совокупностью элементов, формирующих тот или иной промежуточный или оконечный сигнал. Иными словами, на выходе этой группы должна образовываться контрольная величина, например, уровень напряжения, переходной процесс, при этом детали, участвующие в его получении, группируются вблизи друг от друга.
  2. Элементы располагаются таким образом, чтобы их связывающие цепи не загромождали план. Соединительные линии должны быть без резких изломов и с наименьшим количеством пересечений. При этом следует чертить элементы в соответствии с их типовыми положениями.
  3. Группы, связанные между собой, располагаются последовательно слева направо или сверху вниз. Кроме этого, они должны соответствовать структурному изображению.
  4. Менее важные узлы, без которых возможна нормальная работа изделия, например, световая индикации, резервный блок, а также связи между ними вычерчиваются вокруг основной схемы.
  5. Состояния рисуемых элементов соответствуют положению, в котором они находятся при отключённом питании.
  6. Размеры вычерчиваемых элементов должны соответствовать пропорциям, установленным в документах стандартизации. Соединительные линии носят условный характер и не обязаны соответствовать реальным расположениям проводников.

Такой подход при начертании электротехнических принципиальных планов позволяет располагать графические элементы удобным способом, ведущим к лучшему комплексному восприятию.

Для того чтобы схема получалась компактной, были введены нормы, помогающие оптимизировать чертёж. Так, расстояние от точки соединения или пересечения до рисунка элемента принимается равным 5 мм, промежуток между контурами деталей делается 8−10 мм для горизонтального исполнения и 12−15 мм для вертикального. Блоки же располагаются на расстоянии друг от друга порядка 20−40 мм. Но следует понимать, что эти положения носят рекомендательный характер, и если из-за специфики устройства расстояния получаются другими, то уменьшать их и водить изломы считается нецелесообразно.

Элементы цепи

Схемы по электричествуЛюбая электрическая схема состоит из совокупности соединений и деталей. Условно она часто разделяется на первичную часть и вторичную. В радиоэлектронике к первичной цепи относится силовая часть, а к вторичной – исполнительная. В электротехнике это разделение происходит по величине напряжения.

Так, к цепям главной схемы относят элементы, участвующие в выработке и преобразовании основного потока электроэнергии. Через них сигнал попадает на электрооборудование системы конечного энергоснабжения. К вторичным же электротехническим цепям относят участки, на которых мощность обычно не превышает одного киловатта. Они предназначены для осуществления контроля, измерения или учёта расхода энергии, управления работы приборов.

Все элементы, из которых состоит чертёж, принято разделять на три группы:

  • блоки питания и генераторы сигналов;
  • преобразователи энергии, чаще всего являющиеся приёмниками;
  • элементы, обеспечивающие передачу электричества между частями цепи, то есть от источника энергии к конечному потребителю.

Участки, через которые проходят одинаковые токи, называются ветвями, а место соединения двух и более ветвей – узлом. В зависимости от количества замкнутых цепей в схеме, планы называются одно- и многоконтурными. Все детали, из которых состоит схема, обозначаются знаками. Их условно разделяют на электротехнические и электронные.

Принципы изображения

Система обозначения выполняется в соответствии с принятыми рекомендациями ГОСТ. Концевые выводы одиночно стоящего элемента подписываются цифрами или указанием его выводов буквенными обозначениями. Нумерация начинается от точки, подписанной меньшей цифрой.

Если на принципиальной электросхеме вычерчивается группа из одинаковых элементов, то их выводы на ней указываются следующим образом:

  • перед цифрой рисуется буква, обозначающая признак элемента или фазу, например, С – конденсатор, T – транзистор, U, V, W – фазы в трёхфазной цепи;
  • для одинаковых деталей или различных выходов одного элемента, например, микросхема или магазин сопротивлений, их выводы указываются двумя цифрами через точку;
  • вся группа обводится пунктирной линией, обозначающей узел.

Виды электрических схемСхемы можно выполнять как в многолинейном, так и однолинейном изображении. Выводы частей или деталей, которые не задействованы в протекании тока, обозначаются короче, чем контакты используемых элементов. Различные цепи по функциональности отделяются толщиной линий. Но на плане не рекомендуется использовать более трёх толщин.

Для упрощения схемы разрешается объединение электрически не связанных цепей в линию групповой связи, но при переходе к деталям каждую линию выделяют отдельно. В случае разветвления соединителя на нём обозначается номер, но не менее двух раз.

На схеме также указывается:

  • обозначение функциональной группы;
  • упрощённое изображение электронного или электротехнического прибора в виде прямоугольника, в середине которого ставится его обозначение, номер на принципиальной схеме, название, класс.

Обозначения указываются сверху расположения элементов или с их небольшим смещением в правую часть, на свободных участках и без пересечения с другими условными обозначениями. При этом на чертеже могут указываться названия присоединения конца участка или начала.

Распространённые знаки

Открыв ГОСТ или справочник радиолюбителя, можно обнаружить, что условно-графических обозначений существует более нескольких сотен. И это неудивительно, так как, кроме множества радиодеталей и их подвидов, существуют изображения коммутационных устройств, разных типов проводов и кабелей, видов сигналов.

Поэтому их подробное указание займёт несколько листов, но для примера и понятия подхода выполнения изображений следует указать наиболее распространённые условные знаки, которые можно найти практически в любом описании электрической схемы.

Так, ключевые радиоэлементы обозначаются следующим образом:

Принципиальная электросхема

Графическое обозначение в какой-то мере подчёркивает функциональное назначение того или иного электронного прибора. Индуктивность выполняется в виде витков катушки, конденсатор – параллельных линий, подчёркивающих использование обкладок и диэлектрического слоя. Стрелки, используемые на чертежах, обозначают направление протекания тока или преобразованной энергии.

Не исключением являются обозначения, используемые для указания элементов электропроводки. Они также стандартизированы. Разбирающемуся человеку несложно понять, каким образом устроена принципиальная схема и из каких частей она состоит. При этом содержание щитков также имеет своё обозначение. Так, автоматические выключатели, устройства защитного отключения изображаются в виде группы переключающихся контактов с указанием буквенного кода.

Описание электрической схемы

Для обозначений различных форм и полярности электрических сигналов используются простые линии, изображающие их вид. Например, постоянный сигнал чертится прямой линией, а переменной частоты — волнистой. Высокочастотный — тремя волнистыми полосками, располагающимися друг под другом. Прямоугольный импульс или остроугольный соответственно прямоугольником (буква П) или треугольником без основания.

Скачать принципиальную электрическую схему

Немалое значение в обозначениях отведено проводам, кабелям и экранам. В частности, на рисунке указывается полная или частичная экранированность провода, его соединение с землёй, ответвление и соединение. При этом сами значки могут выполняться разным цветом, чтобы визуально легче было воспринимать, к какой группе относятся соединители.

Чтение документа

Зная, какие бывают значки, и разбираясь, что они обозначают, несложно будет прочитать и понять любую принципиальную схему. Так как принципиальная схема не что иное, как графическое отображение входящих в устройство всех его элементов со связывающими проводниками. Она является основным документом при разработке любой системы электрических цепей или электронного устройства. Поэтому любой даже начинающий электрик или радиолюбитель должен уметь её читать. Именно правильное понимание чертежа помогает осваивать азы конструирования, а мастерам быстро и эффективно восстанавливать поломки.

В первую очередь, изучаются элементы, входящие в состав изделия или системы. На схеме отмечаются основные узлы и их назначение. Отдельно изучается каждый узел. Если к схеме нет сопроводительных пояснений, описывающих её работу, на основании начерченных деталей разбирается самостоятельно её принцип действия. Для этого используются справочники или даташиты, выпускаемые производителями деталей. В них обычно подробно указывается, каким способом может использоваться их элемент в электрической цепи с видами его включения и параметрами.

Во вторую очередь, обращается внимание на уточняющую информацию, указанную возле каждого элемента и ключевых точек схемы. Благодаря ей несложно будет определить, какая деталь используется в этом месте или как изменяется сигнал после прохождения определённого узла.

Например, биполярный транзистор имеет как минимум три вывода. При этом для определения его подключения к электрическим связям используют буквенное обозначение базы элемента. Если вид детали непонятен, следует обратить внимание на его название и порядковый номер в схеме. Запомнив эти сведения, идентифицировать элемент, возможно, с помощью спецификации. Это отдельный документ или указываемая рядом возле схемы таблица, содержащая перечень всех компонентов, используемых для конструирования прибора или цепи.

Непосредственно чтение схемы происходит слева направо и начинается от места подачи входного сигнала на устройство. Далее, отслеживается путь его прохождения по электрическим связям, вплоть до выхода изделия или системы.

Пример с описанием

При небольшом опыте работы с электрическими цепями есть смысл начать изучение с простых схем. Их можно придумать самостоятельно, постепенно увеличивая функциональность. Например, классическая схема аналогового блока питания со стабилизируемым напряжением на выходе:

Схема — это графически выполненный документ

  1. ~ 220 В — напряжение, поступающее на схему в вольтах.
  2. 5…14 В — разность потенциалов которая может быть получена на выходе устройства.
  3. + — соответствует прямому направлению прохождения тока.
  4. — — обозначает путь обратного тока.
  5. T — трансформатор с заземлённой обмоткой.
  6. S1 — кнопка коммутирования 220 В.
  7. VDS1 — диодный мост.
  8. КР142ЕН5А — стабилизирующую микросхему.
  9. R2 — регулируемое сопротивление.
  10. VT3, VT4 — выходные транзисторы.

Наука по электричествуВсе остальные элементы играют второстепенную роль, но при этом также важны для обеспечения стабильного сигнала на выходе. Как видно из схемы, напряжение питания из переменной сети 220 вольт через предохранитель 5 А и кнопку S1 поступает на трансформатор. С него сигнал идёт на диодный мост, собранный из четырёх выпрямителей. На его выходе образуется постоянное напряжение требуемого значения, при этом паразитная переменная составляющая убирается с помощью конденсаторов C1 и C2.

Стабилизатор VR1, согласно даташиту, выдаёт на выходе стабильную амплитуду напряжения равную пяти вольтам. Для того чтобы его можно было изменять, введена обратная электрическая связь. То есть его вывод под №8 подключён через управляемый резистор к минусу схемы (земле). Это позволяет с помощью изменения его сопротивления менять величину сигнала на выходе микросхемы. Транзисторы, подключённые к выходу своими базами, являются не чем иным, как эмиттерным повторителем, позволяющим увеличить мощность источника питания.

Важно для правильного восприятия схемы не только понимать символы, но и разбираться в назначении различных электронных и радиотехнических элементов. Тогда без особого труда можно будет определить вид и форму сигнала в любой точке принципиальной схемы, что поможет при ремонте или усовершенствовании электрического устройства или цепи.

rusenergetics.ru

Блок-схемы алгоритмов. ГОСТ. Примеры — Блог программиста

Схемаэто абстракция какого-либо процесса или системы, наглядно отображающая наиболее значимые части. Схемы широко применяются с древних времен до настоящего времени — чертежи древних пирамид, карты земель, принципиальные электрические схемы. Очевидно, древние мореплаватели хотели обмениваться картами и поэтому выработали единую систему обозначений и правил их выполнения. Аналогичные соглашения выработаны для изображения схем-алгоритмов и закреплены ГОСТ и международными стандартами.

На территории Российской Федерации действует единая система программной документации (ЕСПД), частью которой является Государственный стандарт — ГОСТ 19.701-90 «Схемы алгоритмов программ, данных и систем» [1]. Не смотря на то, что описанные в стандарте обозначения могут использоваться для изображения схем ресурсов системы, схем взаимодействия программ и т.п., в настоящей статье описана лишь разработка схем алгоритмов программ.

Рассматриваемый ГОСТ практически полностью соответствует международному стандарту ISO 5807:1985.

Содержание:

  1. Элементы блок-схем алгоритмов
  2. Примеры блок-схем
  3. Нужны ли блок-схемы? Альтернативы

Элементы блок-схем алгоритмов

Блок-схема представляет собой совокупность символов, соответствующих этапам работы алгоритма и соединяющих их линий. Пунктирная линия используется для соединения символа с комментарием. Сплошная линия отражает зависимости по управлению между символами и может снабжаться стрелкой. Стрелку можно не указывать при направлении дуги слева направо и сверху вниз. Согласно п. 4.2.4, линии должны подходить к символу слева, либо сверху, а исходить снизу, либо справа.

Есть и другие типы линий, используемые, например, для изображения блок-схем параллельных алгоритмов, но в текущей статье они, как и ряд специфических символов, не рассматриваются. Рассмотрены лишь основные символы, которых всегда достаточно студентам.

flowcharts_terminatorТерминатор начала и конца работы функции

Терминатором начинается и заканчивается любая функция. Тип возвращаемого значения и аргументов функции обычно указывается в комментариях к блоку терминатора.

flowcharts_dataОперации ввода и вывода данных

В ГОСТ определено множество символов ввода/вывода, например вывод на магнитные ленты, дисплеи и т.п. Если источник данных не принципиален, обычно используется символ параллелограмма. Подробности ввода/вывода могут быть указаны в комментариях.

flowcharts_processВыполнение операций над данными

В блоке операций обычно размещают одно или несколько (ГОСТ не запрещает) операций присваивания, не требующих вызова внешних функций.

flowcharts_solutionБлок, иллюстрирующий ветвление алгоритма

Блок в виде ромба имеет один вход и несколько подписанных выходов. В случае, если блок имеет 2 выхода (соответствует оператору ветвления), на них подписывается результат сравнения — «да/нет». Если из блока выходит большее число линий (оператор выбора), внутри него записывается имя переменной, а на выходящих дугах — значения этой переменной.

flowcharts_procedureВызов внешней процедуры

Вызов внешних процедур и функций помещается в прямоугольник с дополнительными вертикальными линиями.

flowcharts_loopНачало и конец цикла

Символы начала и конца цикла содержат имя и условие. Условие может отсутствовать в одном из символов пары. Расположение условия, определяет тип оператора, соответствующего символам на языке высокого уровня — оператор с предусловием (while) или постусловием (do … while).

flowcharts_preprocessПодготовка данных

Символ «подготовка данных» в произвольной форме (в ГОСТ нет ни пояснений, ни примеров), задает входные значения. Используется обычно для задания циклов со счетчиком.

flowcharts_connectorСоединитель

В случае, если блок-схема не умещается на лист, используется символ соединителя, отражающий переход потока управления между листами. Символ может использоваться и на одном листе, если по каким-либо причинам тянуть линию не удобно.

flowcharts_commentКомментарий

Комментарий может быть соединен как с одним блоком, так и группой. Группа блоков выделяется на схеме пунктирной линией.

Примеры блок-схем

В качестве примеров, построены блок-схемы очень простых алгоритмов сортировки, при этом акцент сделан на различные реализации циклов, т.к. у студенты делают наибольшее число ошибок именно в этой части.

Сортировка вставками

Массив в алгоритме сортировки вставками разделяется на отсортированную и еще не обработанную части. Изначально отсортированная часть состоит из одного элемента, и постепенно увеличивается.

На каждом шаге алгоритма выбирается первый элемент необработанной части массива и вставляется в отсортированную так, чтобы в ней сохранялся требуемый порядок следования элементов. Вставка может выполняться как в конец массива, так и в середину. При вставке в середину необходимо сдвинуть все элементы, расположенные «правее» позиции вставки на один элемент вправо. В алгоритме используется два цикла — в первом выбираются элементы необработанной части, а во втором осуществляется вставка.

insertsort_flowchartБлок-схема алгоритма сортировки вставками

В приведенной блок-схеме для организации цикла используется символ ветвления. В главном цикле (i < n) перебираются элементы необработанной части массива. Если все элементы обработаны — алгоритм завершает работу, в противном случае выполняется поиск позиции для вставки i-того элемента. Искомая позиция будет сохранена в переменной j в результате выполнения внутреннего цикла, осуществляющем сдвиг элементов до тех пор, пока не будет найден элемент, значение которого меньше i-того.

На блок-схеме показано каким образом может использоваться символ перехода — его можно использовать не только для соединения частей схем, размещенных на разных листах, но и для сокращения количества линий. В ряде случаев это позволяет избежать пересечения линий и упрощает восприятие алгоритма.

Сортировка пузырьком

Сортировка пузырьком, как и сортировка вставками, использует два цикла. Во вложенном цикле выполняется попарное сравнение элементов и, в случае нарушения порядка их следования, перестановка. В результате выполнения одной итерации внутреннего цикла, максимальный элемент гарантированно будет смещен в конец массива. Внешний цикл выполняется до тех пор, пока весь массив не будет отсортирован.

bubblesort_flowchartБлок-схема алгоритма сортировки пузырьком

На блок-схеме показано использование символов начала и конца цикла. Условие внешнего цикла (А) проверяется в конце (с постусловием), он работает до тех пор, пока переменная hasSwapped имеет значение true. Внутренний цикл использует предусловие для перебора пар сравниваемых элементов. В случае, если элементы расположены в неправильном порядке, выполняется их перестановка посредством вызова внешней процедуры (swap). Для того, чтобы было понятно назначение внешней процедуры и порядок следования ее аргументов, необходимо писать комментарии. В случае, если функция возвращает значение, комментарий может быть написан к символу терминатору конца.

Сортировка выбором

В сортировке выбором массив разделяется на отсортированную и необработанную части. Изначально отсортированная часть пустая, но постепенно она увеличивается. Алгоритм производит поиск минимального элемента необработанной части и меняет его местами с первым элементом той же части, после чего считается, что первый элемент обработан (отсортированная часть увеличивается).

selectsort_flowchartБлок-схема сортировки выбором

На блок-схеме приведен пример использования блока «подготовка», а также показано, что в ряде случаев можно описывать алгоритм более «укрупнённо» (не вдаваясь в детали). К сортировке выбором не имеют отношения детали реализации поиска индекса минимального элемента массива, поэтому они могут быть описаны символом вызова внешней процедуры. Если блок-схема алгоритма внешней процедуры отсутствует, не помешает написать к символу вызова комментарий, исключением могут быть функции с говорящими названиями типа swap, sort, … .

На блоге можно найти другие примеры блок-схем:

Часть студентов традиционно пытается рисовать блок-схемы в Microsoft Word, но это оказывается сложно и не удобно. Например, в MS Word нет стандартного блока для терминатора начала и конца алгоритма (прямоугольник со скругленными краями, а не овал). Наиболее удобными, на мой взгляд, являются утилиты MS Visio и yEd [5], обе они позволяют гораздо больше, чем строить блок-схемы (например рисовать диаграммы UML), но первая является платной и работает только под Windows, вторая бесплатная и кроссплатфомренная. Все блок-схемы в этой статье выполнены с использованием yEd.

Нужны ли блок-схемы? Альтернативы

Частные конторы никакие блок-схемы не используют, в книжках по алгоритмам [6] вместо них применяют словесное описание (псевдокод) как более краткую форму. Возможно блок-схемы применяют на государственных предприятиях, которые должны оформлять документацию согласно требованиям ЕСПД, но есть сомнения — даже для регистрации программы в Государственном реестре программ для ЭВМ никаких блок-схем не требуется.

Тем не менее, рисовать блок-схемы заставляют школьников (примеры из учебников ГОСТ не соответствуют) — выносят вопросы на государственные экзамены (ГИА и ЕГЭ), студентов — перед защитой диплом сдается на нормоконтроль, где проверяется соответствие схем стандартам.

Разработка блок-схем выполняется на этапах проектирования и документирования, согласно каскадной модели разработки ПО, которая сейчас почти не применяется, т.к. сопровождается большими рисками, связанными с ошибками на этапах проектирования.

Появляются подозрения, что система образования прогнила и отстала лет на 20, однако аналогичная проблема наблюдается и за рубежом. Международный стандарт ISO 5807:1985 мало чем отличается от ГОСТ 19.701-90, более нового стандарта за рубежом нет. Там же производится множество программ для выполнения этих самых схем — Dia, MS Visio, yEd, …, а значит списывать их не собираются. Вместо блок-схем иногда применяют диаграммы деятельности UML [6], однако удобнее они оказываются, разве что при изображении параллельных алгоритмов.

Периодически поднимается вопрос о том, что ни блок-схемы, ни UML не нужны, да и документация тоже не нужна. Об этом твердят программисты, придерживающиеся методологии экстремального программирования (XP) [7], ходя даже в их кругу нет единого мнения.

В ряде случаев, программирование невозможно без рисования блок-схем, т.к. это один процесс — существуют визуальные языки программирования, такие как ДРАКОН [8], кроме того, блок-схемы используются для верификации алгоритмов (формального доказательства их корректности) методом индуктивных утверждений Флойда [9].

В общем, единого мнения нет. Очевидно, есть области, в которых без чего-то типа блок-схем обойтись нельзя, но более гибкой альтернативы нет. Для формальной верификации необходимо рисовать подробные блок-схемы, но для проектирования и документирования такие схемы не нужны — я считаю разумным утверждение экстремальных программистов о том, что нужно рисовать лишь те схемы, которые помогают в работе и не требуют больших усилий для поддержания в актуальном состоянии [10].

Список использованных источников:

  1. ГОСТ 19.701–90 (ИСО 5807–85) «Единая система программной документа­ции».
  2. Алгоритм. Свойства алгоритма \ https://pro-prof.com/archives/578
  3. Алгоритмы сортировки слиянием и быстрой сортировки \ https://pro-prof.com/archives/813
  4. yEd Graph Editor \ https://www.yworks.com/products/yed
  5. Книги: алгоритмы \ https://pro-prof.com/books-algorithms
  6. Рамбо Дж., Якобсон А., Буч Г. UML: специальный справочник. -СПб.: Питер, 2002. -656 с.
  7. Кент Бек Экстремальное программирование: разработка через тестирование – СПб.: Питер – 2003
  8. Визуальный язык ДРАКОН \ https://drakon.su/
  9. Шилов Н.В. Верификация шаблонов алгоритмов для метода отката и метода ветвей и границ. Моделирование и анализ информационных систем, ISSN 1818 – 1015, т.18, №4, 2011
  10. Брукс Ф., Мифический человеко — месяц или как создаются программные системы. СПб. Символ Плюс, 1999 — 304 с. ил.

pro-prof.com

Условные обозначения в электрических схемах по ГОСТ

Любые электрические цепи могут быть представлены в виде чертежей (принципиальных и монтажных схем), оформление которых должно соответствовать стандартам ЕСКД. Эти нормы распространяются как на схемы электропроводки или силовых цепей, так и электронные приборы. Соответственно, чтобы «читать» такие документы, необходимо понимать условные обозначения в электрических схемах.

Нормативные документы

Учитывая большое количество электроэлементов, для их буквенно-цифровых (далее БО) и условно графических обозначений (УГО) был разработан ряд нормативных документов исключающих разночтение. Ниже представлена таблица, в которой представлены основные стандарты.

Таблица 1. Нормативы графического обозначения отдельных элементов в монтажных и принципиальных электрических схемах.

Номер ГОСТа Краткое описание
2.710 81 В данном документе собраны требования ГОСТа к БО различных типов электроэлементов, включая электроприборы.
2.747 68 Требования к размерам отображения элементов в графическом виде.
21.614 88 Принятые нормы  для планов электрооборудования и проводки.
2.755 87 Отображение на схемах коммутационных устройств и контактных соединений
2.756 76 Нормы для воспринимающих частей электромеханического оборудования.
2.709 89 Настоящий стандарт регулирует нормы, в соответствии с которыми на схемах обозначаются контактные соединения и провода.
21.404 85 Схематические обозначения для оборудования, используемого в системах автоматизации

 

Следует учитывать, что элементная база со временем меняется, соответственно вносятся изменения и в нормативные документы, правда это процесс более инертен. Приведем простой пример, УЗО и дифавтоматы широко эксплуатируются в России уже более десятка лет, но единого стандарта по нормам ГОСТ 2.755-87 для этих устройств до сих пор нет, в отличие от автоматических выключателей. Вполне возможно, в ближайшее время это вопрос будет урегулирован. Чтобы быть в курсе подобных нововведений, профессионалы отслеживают изменения в нормативных документах, любителям это делать не обязательно, достаточно знать расшифровку основных обозначений.

Виды электрических схем

В соответствии с нормами ЕСКД под схемами подразумеваются графические документы, на которых при помощи принятых обозначений отображаются основные элементы или узлы конструкции, а также объединяющие их связи. Согласно принятой классификации различают десять видов схем, из которых в электротехнике, чаще всего, используется три:

  • Функциональная, на ней представлены узловые элементы (изображаются как прямоугольники), а также соединяющие их линии связи. Характерная особенность такой схемы – минимальная детализация. Для описания основных функций узлов, отображающие их прямоугольники, подписываются стандартными буквенными обозначениями. Это могут быть различные части изделия, отличающиеся функциональным назначением, например, автоматический диммер с фотореле в качестве датчика или обычный телевизор. Пример такой схемы представлен ниже. Функциональная схема телевизионного приемникаПример функциональной схемы телевизионного приемника
  • Принципиальная. Данный вид графического документа подробно отображает как используемые в конструкции элементы, так и их связи и контакты. Электрические параметры некоторых элементов могут быть отображены, непосредственно в документе, или представлены отдельно в виде таблицы. Пример принципиальной схемы фрезерного станкаПример принципиальной схемы фрезерного станка

Если на схеме отображается только силовая часть установки, то она называется однолинейной, если приведены все элементы, то – полной.

Пример однолинейной схемыПример однолинейной схемы
  • Монтажные электрические схемы. В данных документах применяются позиционные обозначения элементов, то есть указывается их место расположения на плате, способ и очередность монтажа. Монтажная схема  стационарного сигнализатора горючих газовМонтажная схема  стационарного сигнализатора горючих газов

Если на чертеже отображается проводка квартиры, то места расположения осветительных приборов, розеток и другого оборудования указываются на плане. Иногда можно услышать, как такой документ называют схемой электроснабжения, это неверно, поскольку последняя отображает способ подключения потребителей к подстанции или другому источнику питания.

Разобравшись с электрическими схемами, можем переходить к обозначениям указанных на них элементов.

Графические обозначения

Для каждого типа графического документа предусмотрены свои обозначения, регулируемые соответствующими нормативными документами. Приведем в качестве примера основные графические обозначения для разных видов электрических схем.

Примеры УГО в функциональных схемах

Ниже представлен рисунок с изображением основных узлов систем автоматизации.

Примеры условных обозначений электроприборовПримеры условных обозначений электроприборов и средств автоматизации в соответствии с ГОСТом 21.404-85

Описание обозначений:

  • А – Основные (1) и допускаемые (2) изображения приборов, которые устанавливаются за пределами электрощита или распределительной коробки.
  • В – Тоже самое, что и пункт А, за исключением того, что элементы располагаются на пульте или электрощите.
  • С – Отображение исполнительных механизмов (ИМ).
  • D – Влияние ИМ на регулирующий орган (далее РО) при отключении питания:
  1. Происходит открытие РО
  2. Закрытие РО
  3. Положение РО остается неизменным.
  • Е — ИМ, на который дополнительно установлен ручной привод. Данный символ может использоваться для любых положений РО, указанных в пункте D.
  • F- Принятые отображения линий связи:
  1. Общее.
  2. Отсутствует соединение при пересечении.
  3. Наличие соединения при пересечении.

УГО в однолинейных и полных электросхемах

Для данных схем существует несколько групп условных обозначений, приведем наиболее распространенные из них. Для получения полной информации необходимо обратиться к нормативным документам, номера государственных стандартов будут приведены для каждой группы.

Источники питания.

Для их обозначения приняты символы, приведенные на рисунке ниже.

УГО источников питания на принципиальных схемахУГО источников питания на принципиальных схемах (ГОСТ 2.742-68 и ГОСТ 2.750.68)

Описание обозначений:

  • A – источник с постоянным напряжением, его полярность обозначается символами «+» и «-».
  • В – значок электричества, отображающий переменное напряжение.
  • С – символ переменного и постоянного напряжения, используется в тех случаях, когда устройство может быть запитано от любого из этих источников.
  • D – Отображение аккумуляторного или гальванического источника питания.
  • E- Символ батареи, состоящей из нескольких элементов питания.

Линии связи

Базовые элементы электрических соединителей представлены ниже.

Обозначение линий связи на принципиальных схемахОбозначение линий связи на принципиальных схемах (ГОСТ 2.721-74 и ГОСТ 2.751.73)

Описание обозначений:

  • А – Общее отображение, принятое для различных видов электрических связей.
  • В – Токоведущая или заземляющая шина.
  • С – Обозначение экранирования, может быть электростатическим (помечается символом «Е») или электромагнитным («М»).
  • D — Символ заземления.
  • E – Электрическая связь с корпусом прибора.
  • F – На сложных схемах, из нескольких составных частей, таким образом обозначается обрыв связи, в таких случаях «Х» это информация о том, где будет продолжена линия (как правило, указывается номер элемента).
  • G – Пересечение с отсутствием соединения.
  • H – Соединение в месте пересечения.
  • I – Ответвления.

Обозначения электромеханических приборов и контактных соединений

Примеры обозначения магнитных пускателей, реле, а также контактов коммуникационных устройств, можно посмотреть ниже.

УГО, принятые для электромеханических устройств и контакторовУГО, принятые для электромеханических устройств и контакторов (ГОСТы 2.756-76, 2.755-74, 2.755-87)

Описание обозначений:

  • А – символ катушки электромеханического прибора (реле, магнитный пускатель и т.д.).
  • В – УГО воспринимающей части электротепловой защиты.
  • С – отображение катушки устройства с механической блокировкой.
  • D – контакты коммутационных приборов:
  1. Замыкающие.
  2. Размыкающие.
  3. Переключающие.
  • Е – Символ для обозначения ручных выключателей (кнопок).
  • F – Групповой выключатель (рубильник).

УГО электромашин

Приведем несколько примеров, отображения электрических машин (далее ЭМ) в соответствии с действующим стандартом.

Обозначение электродвигателей и генераторовОбозначение электродвигателей и генераторов на принципиальных схемах (ГОСТ 2.722-68)

Описание обозначений:

  • A – трехфазные ЭМ:
  1. Асинхронные (ротор короткозамкнутый).
  2. Тоже, что и пункт 1, только в двухскоростном исполнении.
  3. Асинхронные ЭМ с фазным исполнением ротора.
  4. Синхронные двигатели и генераторы.
  • B – Коллекторные, с питанием от постоянного тока:
  1. ЭМ с возбуждением на постоянном магните.
  2. ЭМ с катушкой возбуждения.
Обозначение электродвигателей на схемахОбозначение электродвигателей на схемах

УГО трансформаторов и дросселей

С примерами графических обозначений данных устройств можно ознакомиться на представленном ниже рисунке.

Правильные обозначения трансформаторов, катушек индуктивности и дросселейПравильные обозначения трансформаторов, катушек индуктивности и дросселей (ГОСТ 2.723-78)

Описание обозначений:

  • А – Данным графическим символом могут быть обозначены катушки индуктивности или обмотки трансформаторов.
  • В – Дроссель, у которого имеется ферримагнитный сердечник (магнитопровод).
  • С – Отображение двухкатушечного трансформатора.
  • D – Устройство с тремя катушками.
  • Е – Символ автотрансформатора.
  • F – Графическое отображение ТТ (трансформатора тока).

Обозначение измерительных приборов и радиодеталей

Краткий обзор УГО данных электронных компонентов показан ниже. Тем, кто хочет более широко ознакомиться с этой информацией рекомендуем просмотреть ГОСТы 2.729 68 и 2.730 73.

Примеры условных графических обозначенийПримеры условных графических обозначений электронных компонентов и измерительных приборов

Описание обозначений:

  1. Счетчик электроэнергии.
  2. Изображение амперметра.
  3. Прибор для измерения напряжения сети.
  4. Термодатчик.
  5. Резистор с постоянным номиналом.
  6. Переменный резистор.
  7. Конденсатор (общее обозначение).
  8. Электролитическая емкость.
  9. Обозначение диода.
  10. Светодиод.
  11. Изображение диодной оптопары.
  12. УГО транзистора (в данном случае npn).
  13. Обозначение предохранителя.

УГО осветительных приборов

Рассмотрим, как на принципиальной схеме отображаются электрические лампы.

Пример того, как указываются лампочки на схемах (ГОСТ 2.732-68)Пример того, как указываются лампочки на схемах (ГОСТ 2.732-68)

Описание обозначений:

  • А – Общее изображение ламп накаливания (ЛН).
  • В — ЛН в качестве сигнализатора.
  • С – Типовое обозначение газоразрядных ламп.
  • D – Газоразрядный источник света повышенного давления (на рисунке приведен пример исполнения с двумя электродами)

Обозначение элементов в монтажной схеме электропроводки

Завершая тему графических обозначений, приведем примеры отображения розеток и выключателей.

Пример изображения на монтажных схемах розеток скрытой установкиПример изображения на монтажных схемах розеток скрытой установки

Как изображаются розетки других типов, несложной найти в нормативных документах, которые доступны в сети.

Обозначение выключатели скрытой установкиОбозначение выключатели скрытой установкиОбозначение розеток и выключателейОбозначение розеток и выключателей

Видео по теме:

Буквенные обозначения

В электрических схемах помимо графических обозначений также используются буквенные, поскольку без последних чтение чертежей будет довольно проблематичным. Буквенно-цифровая маркировка так же, как и УГО регулируется нормативными документами, для электро это ГОСТ 7624 55. Ниже представлена таблица с БО для основных компонентов электросхем.

Буквенные обозначения основных элементовБуквенные обозначения основных элементов

К сожалению, размеры данной статьи не позволяют привести все правильные графические и буквенные обозначения, но мы указали нормативные документы, из которых можно получить всю недостающую информацию. Следует учитывать, что действующие стандарты могут меняться в зависимости от модернизации технической базы, поэтому, рекомендуем отслеживать выход новых дополнений к нормативным актам.

www.asutpp.ru

примеры, элементы, построение. Блок-схемы алгоритмов :: SYL.ru

В этой статье будут рассмотрены примеры блок-схем, которые могут встретиться вам в учебниках по информатике и другой литературе. Блок-схема представляет собой алгоритм, по которому решается какая-либо задача, поставленная перед разработчиком. Сначала нужно ответить на вопрос, что такое алгоритм, как он представляется графически, а самое главное – как его решить, зная определенные параметры. Нужно сразу отметить, что алгоритмы бывают нескольких видов.

Что такое алгоритм?

Это слово ввел в обиход математик Мухаммед аль-Хорезми, который жил в период 763-850 года. Именно он является человеком, который создал правила выполнения арифметических действий (а их всего четыре). А вот ГОСТ от 1974 года, который гласит, что:

Алгоритм – это точное предписание, которое определяет вычислительный процесс. Причем имеется несколько переменных с заданными значениями, которые приводят расчеты к искомому результату.

Алгоритм позволяет четко указать исполнителю выполнять строгую последовательность действий, чтобы решить поставленную задачу и получить результат. Разработка алгоритма – это разбивание одной большой задачи на некую последовательность шагов. Причем разработчик алгоритма обязан знать все особенности и правила его составления.

Особенности алгоритма

Всего можно выделить восемь особенностей алгоритма (независимо от его вида):

  1. Присутствует функция ввода изначальных данных.
  2. Есть вывод некоего результата после завершения алгоритма. Нужно помнить, что алгоритм нужен для того, чтобы достичь определенной цели, а именно – получить результат, который имеет прямое отношение к исходным данным.
  3. У алгоритма должна быть структура дискретного типа. Он должен представляться последовательными шагами. Причем каждый следующий шаг может начаться только после завершения предыдущего.
  4. Алгоритм должен быть однозначным. Каждый шаг четко определяется и не допускает произвольной трактовки.
  5. Алгоритм должен быть конечным – необходимо, чтобы он выполнялся за строго определенное количество шагов.
  6. Алгоритм должен быть корректным – задавать исключительно верное решение поставленной задачи.
  7. Общность (или массовость) – он должен работать с различными исходными данными.
  8. Время, которое дается на решение алгоритма, должно быть минимальным. Это определяет эффективность решения поставленной задачи.

А теперь, зная, какие существуют блок-схемы алгоритмов, можно приступить к рассмотрению способов их записи. А их не очень много.

Словесная запись

Такая форма, как правило, применяется при описании порядка действий для человека: «Пойди туда, не знаю куда. Принеси то, не знаю что».

Конечно, это шуточная форма, но суть понятна. В качестве примера можно привести еще, например, привычную запись на стеклах автобусов:«При аварии выдернуть шнур, выдавить стекло».

Здесь четко ставится условие, при котором нужно выполнить два действия в строгой последовательности. Но это самые простые алгоритмы, существуют и более сложные. Иногда используются формулы, спецобозначения, но при обязательном условии – исполнитель должен все понимать.

Допускается изменять порядок действий, если необходимо вернуться, например, к предыдущей операции либо обойти какую-то команду при определенном условии. При этом команды желательно нумеровать и обязательно указывается команда, к которой происходит переход: «Закончив все манипуляции, повторяете пункты с 3 по 5».

Запись в графической форме

В этой записи участвуют элементы блок-схем. Все элементы стандартизированы, у каждой команды имеется определенная графическая запись. А конкретная команда должна записываться внутри каждого из блоков обычным языком или математическими формулами. Все блоки должны соединяться линиями – они показывают, какой именно порядок у выполняемых команд. Собственно, этот тип алгоритма более подходит для использования в программном коде, нежели словесный.

Запись на языках программирования

В том случае, если алгоритм необходим для того, чтобы задачу решала программа, установленная на ПК, то нужно его записывать специальным кодом. Для этого существует множество языков программирования. И алгоритм в этом случае называется программой.

Блок-схемы

Блок-схема – это представление алгоритма в графической форме. Все команды и действия представлены геометрическими фигурами (блоками). Внутри каждой фигуры вписывается вся информация о тех действиях, которые нужно выполнить. Связи изображены в виде обычных линий со стрелками (при необходимости).

Для оформления блок-схем алгоритмов имеется ГОСТ 19.701-90. Он описывает порядок и правила создания их в графической форме, а также основные методы решения. В этой статье приведены основные элементы блок-схем, которые используются при решении задач, например, по информатике. А теперь давайте рассмотрим правила построения.

Основные правила составления блок-схемы

Можно выделить такие особенности, которые должны быть у любой блок-схемы:

  1. Обязательно должно присутствовать два блока – «Начало» и «Конец». Причем в единичном экземпляре.
  2. От начального блока до конечного должны быть проведены линии связи.
  3. Из всех блоков, кроме конечного, должны выходить линии потока.
  4. Обязательно должна присутствовать нумерация всех блоков: сверху вниз, слева направо. Порядковый номер нужно проставлять в левом верхнем углу, делая разрыв начертания.
  5. Все блоки должны быть связаны друг с другом линиями. Именно они должны определять последовательность, с которой выполняются действия. Если поток движется снизу вверх или справа налево (другими словами, в обратном порядке), то обязательно рисуются стрелки.
  6. Линии делятся на выходящие и входящие. При этом нужно отметить, что одна линия является для одного блока выходящей, а для другого входящей.
  7. От начального блока в схеме линия потока только выходит, так как он является самым первым.
  8. А вот у конечного блока имеется только вход. Это наглядно показано на примерах блок-схем, которые имеются в статье.
  9. Чтобы проще было читать блок-схемы, входящие линии изображаются сверху, а исходящие снизу.
  10. Допускается наличие разрывов в линиях потока. Обязательно они помечаются специальными соединителями.
  11. Для облегчения блок-схемы разрешается всю информацию прописывать в комментариях.

Графические элементы блок-схем для решения алгоритмов представлены в таблице:

Линейный тип алгоритмов

Это самый простой вид, который состоит из определенной последовательности действий, они не зависят от того, какие данные вписаны изначально. Есть несколько команд, которые выполняются однократно и только после того, как будет сделана предшествующая. Линейная блок-схема выглядит таким образом:

Пример линейного алгоритма

Причем связи могут идти как сверху вниз, так и слева направо. Используется такая блок-схема для записи алгоритмов вычислений по простым формулам, у которых не имеется ограничений на значения переменных, входящих в формулы для расчета. Линейный алгоритм – это составная часть сложных процессов вычисления.

Разветвляющиеся алгоритмы

Блок-схемы, построенные по таким алгоритмам, являются более сложными, нежели линейные. Но суть не меняется. Разветвляющийся алгоритм – это процесс, в котором дальнейшее действие зависит от того, как выполняется условие и какое получается решение. Каждое направление действия – это ветвь.

Разновидности циклов для решения алгоритмов

На схемах изображаются блоки, которые называются «Решение». У него имеется два выхода, а внутри прописывается логическое условие. Именно от того, как оно будет выполнено, зависит дальнейшее движение по схеме алгоритма. Можно разделить разветвляющиеся алгоритмы на три группы:

  1. «Обход» – при этом одна из веток не имеет операторов. Другими словами, происходит обход нескольких действий другой ветки.
  2. «Разветвление» – каждая ветка имеет определенный набор выполняемых действий.
  3. «Множественный выбор» – это разветвление, в котором есть несколько веток и каждая содержит в себе определенный набор выполняемых действий. Причем есть одна особенность – выбор направления напрямую зависит от того, какие заданы значения выражений, входящих в алгоритм.

Это простые алгоритмы, которые решаются очень просто. Теперь давайте перейдем к более сложным.

Циклический алгоритм

Здесь все предельно понятно – циклическая блок-схема представляет алгоритм, в котором многократно повторяются однотипные вычисления. По определению, цикл – это определенная последовательность каких-либо действий, выполняемая многократно (более, чем один раз). И можно выделить несколько типов циклов:

  1. У которых известно число повторений действий (их еще называют циклами со счетчиком).
  2. У которых число повторений неизвестно – с постусловием и предусловием.

Независимо от того, какой тип цикла используется для решения алгоритма, у него обязательно должна присутствовать переменная, при помощи которой происходит выход. Именно она определяет количество повторений цикла. Рабочая часть (тело) цикла – это определенная последовательность действий, которая выполняется на каждом шаге. А теперь более детально рассмотрим все типы циклов, которые могут встретиться при составлении алгоритмов и решении задач по информатике.

Циклы со счетчиками

На рисунке изображена простая блок-схема, в которой имеется цикл со счетчиком. Такой тип алгоритмов показывает, что заранее известно количество повторений данного цикла. И это число фиксировано. При этом переменная, считающая число шагов (повторений), так и называется – счетчик. Иногда в учебниках можно встретить иные определения – параметр цикла, управляющая переменная.

Изображение цикла со счетчиком

Блок-схема очень наглядно иллюстрирует, как работает цикл со счетчиком. Прежде чем приступить к выполнению первого шага, нужно присвоить начальное значение счетчику – это может быть любое число, оно зависит от конкретного алгоритма. В том случае, когда конечное значение меньше величины счетчика, начнет выполняться определенная группа команд, которые составляют тело цикла.

После того, как тело будет выполнено, счетчик меняется на величину шага счетчика, обозначенную буквой h. В том случае, если значение, которое получится, будет меньше конечного, цикл будет продолжаться. И закончится он лишь в тогда, когда конечное значение будет меньше, чем счетчик цикла. Только в этом случае произойдет выполнение того действия, которое следует за циклом.

Как изображается счетчик цикла

Обычно в обозначениях блок-схем используется блок, который называется «Подготовка». В нем прописывается счетчик, а затем указываются такие данные: начальное и конечное значения, шаг изменения. На блок-схеме это параметры I н, Ik и h, соответственно. В том случае, когда h=1, величину шага не записывают. В остальных случаях делать это обязательно. Необходимо придерживаться простого правила – линия потока должна входить сверху. А линия потока, которая выходит снизу (или справа, в зависимости от конкретного алгоритма), должна показывать переход к последующему оператору.

Теперь вы полностью изучили описание блок-схемы, изображенной на рисунке. Можно перейти к дальнейшему изучению. Когда используется цикл со счетчиком, требуется соблюдать определенные условия:

  1. В теле не разрешается изменять (принудительно) значение счетчика.
  2. Запрещено передавать управление извне оператору тела. Другими словами, войти в цикл можно только из его начала.

Циклы с предусловием

Этот тип циклов применяется в тех случаях, когда количество повторений заранее неизвестно. Цикл с предусловием – это тип алгоритма, в котором непосредственно перед началом выполнения тела осуществляется проверка условия, при котором допускается переход к следующему действию. Обратите внимание на то, как изображаются элементы блок-схемы.

В том случае, когда условие выполняется (утверждение истинно), происходит переход к началу тела цикла. Непосредственно в нем изменяется значение хотя бы одной переменной, влияющей на значение поставленного условия. Если не придерживаться этого правила, получим «зацикливание». В том случае, если после следующей проверки условия выполнения тела цикла оказывается, что оно ложное, то происходит выход.

В блок-схемах алгоритмов допускается осуществлять проверку не истинности, а ложности начального условия. При этом из цикла произойдет выход только в том случае, если значение условия окажется истинным. Оба варианта правильные, их использование зависит от того, какой конкретно удобнее использовать для решения той или иной задачи. Такой тип цикла имеет одну особенность – тело может не выполниться в случае, когда условие ложно или истинно (в зависимости от варианта, который применяется для решения алгоритма).

Ниже приведена блок-схема, которая описывает все эти действия:

Изображение цикла с предусловием

Если внимательно присмотреться, то этот вид циклов чем-то похож на предыдущий. Самостоятельно построить блок-схему, описывающую этот цикл, мы сейчас и попробуем. Особенность заключается в том, что неизвестно заранее число повторений. А условие задается уже после того, как произошел выход из тела. Отсюда видно, что тело, независимо от решения, будет выполняться как минимум один раз. Для наглядности взгляните на блок-схему, описывающую выполнение условия и операторов:

Изображение цикла с постусловием

Ничего сложного в построении алгоритмов с циклами нет, достаточно в них только один раз разобраться. А теперь перейдем к более сложным конструкциям.

Сложные циклы

Сложные – это такие конструкции, внутри которых есть один или больше простых циклов. Иногда их называют вложенными. При этом те конструкции, которые охватывают иные циклы, называют «внешними». А те, которые входят в конструкцию внешних – внутренними. При выполнении каждого шага внешнего цикла происходит полная прокрутка внутреннего, как представлено на рисунке:

Пример сложного цикла

Вот и все, вы рассмотрели основные особенности построения блок-схем для решения алгоритмов, знаете принципы и правила. Теперь можно рассмотреть конкретные примеры блок-схем из жизни. Например, в психологии такие конструкции используются для того, чтобы человек решил какой-то вопрос:

Пример из жизни решения алгоритма

Или пример из биологии для решения поставленной задачи:

Второй пример решения алгоритма по блок-схеме

Решение задач с блок-схемами

А теперь рассмотрим примеры задач с блок-схемами, которые могут попасться в учебниках информатики. Например, задана блок-схема, по которой решается какой-то алгоритм:

Решение задачи по математике

При этом пользователь самостоятельно вводит значения переменных. Допустим, х=16, а у=2. Процесс выполнения такой:

  1. Производится ввод значений х и у.
  2. Выполняется операция преобразования: х=√16=4.
  3. Выполняется условие: у=у2=4.
  4. Производится вычисление: х=(х+1)=(4+1)=5.
  5. Дальше вычисляется следующая переменная: у=(у+х)=(5+4)=9.
  6. Выводится решение: у=9.

На этом примере блок-схемы по информатике хорошо видно, как происходит решение алгоритма. Нужно обратить внимание на то, что значения х и у задаются на начальном этапе и они могут быть любыми.

www.syl.ru

Виды и типы электрических схем, их характеристика и назначение

Электрическая схема представляет собой документ, в котором по правилам ГОСТ обозначаются связи между составными частями устройств, работающих за счет протекания электроэнергии. Как Вы понимаете, этот чертеж дает понимание электрикам о том, как работает установка и из каких элементов она состоит. Основное назначение электросхемы – помощь в подключении установок, а также поиске неисправности в цепи. Далее мы расскажем, какие бывают виды и типы электрических схем, предоставив краткое описание, характеристики и примеры каждой разновидности.

Общая классификация

Для начала следует разобраться, что подразумевают под типами, а что под видами документов. Итак, согласно ГОСТ 2.701-84, существуют следующие виды схем (в скобках краткое обозначение):

  1. Электрические (Э).
  2. Гидравлические (Г).
  3. Пневматические (П).
  4. Газовые (Х).
  5. Кинематические (К).
  6. Вакуумные (В).
  7. Оптические (Л).
  8. Энергетические (Р).
  9. Деления (Е).
  10. Комбинированные (С).

Что, касается типов, основными считаются:

  1. Структурные (1).
  2. Функциональные (2).
  3. Принципиальные (полные) (3).
  4. Соединений (монтажные) (4).
  5. Подключения (5).
  6. Общие (6).
  7. Расположение (7).
  8. Объединенные (8).

Исходя из указанных обозначений, можно по наименованию электросхемы понять ее вид и тип. Как пример, документ с названием Э3 является принципиальной электрической схемой. С виду она выглядит так:

Электросхема Э3

Далее мы подробно рассмотрим, назначение и состав каждой из перечисленных типов электросхем. Рекомендуем перед этим ознакомиться со стандартными условными обозначениями на схемах, чтобы было еще проще понять, что собой представляет каждый вариант чертежа.

Назначение каждой электросхемы

Структурная

Этот тип документа является наиболее простым и дает понимание о том, как работает электроустановка и из чего она состоит. Графическое изображение всех элементов цепи позволяет изначально увидеть общую картину, чтобы переходить к более сложному процессу подключения или же ремонта. Порядок чтения обозначается стрелочками и поясняющими надписями, что позволяет разобраться в структурной электрической схеме даже начинающему электрику. Принцип построения Вы можете увидеть на примере ниже:

Структурная

Функциональная

Функциональная электросхема установки, по сути, не слишком отличается от структурной. Единственное отличие – более подробное описание всех составляющих узлов цепи. Выглядит этот документ следующим образом:

Функциональная

 

Принципиальная

Принципиальная электрическая схема чаще всего применяется в распределительных сетях, т.к. дает самое раскрытое пояснение о том, как работает рассматриваемое электрооборудование. На таком чертеже должны обязательно быть указаны все функциональные узлы цепи и вид связи между ними. В свою очередь, принципиальная электросхема может иметь две разновидности: однолинейная или полная. В первом случае на чертеже изображают только первичные сети, называемые также силовыми. Пример однолинейного изображения Вы можете увидеть ниже:

Однолинейная

Полная принципиальная схема может быть развернутой или элементной. Если электроустановка несложная и на один главный чертеж можно нанести все пояснения, достаточно сделать развернутый план. Если же Вы имеете дело со сложной аппаратурой, которая имеет в составе цепь управления, автоматизации и измерения, лучше разнести все отдельные узлы на разные листы, чтобы не запутаться.Полная

Существует также принципиальная электросхема изделия. Этот тип документа представляет собой своеобразную выкопировку из общего плана, на которой обозначено только, как работает и из чего состоит определенный узел.

Монтажная

Эту разновидность электрических схем мы чаще всего используем на сайте, когда рассказываем о том, как самостоятельно выполнить монтаж электропроводки. Дело в том, что на монтажной электросхеме можно показать точное расположение всех элементов цепи, способ их соединения, а также буквенно-цифровые характеристики составляющих чертеж установок. Если взять за пример схему электропроводки в однокомнатной квартире, на ней мы увидим, где нужно размещать розетки, выключатели, светильники и остальные изделия.

Электроснабжение однокомнатной квартиры

Основное назначение монтажной схемы – руководство для проведения электромонтажных работ. Согласно подготовленному чертежу можно понять, где, что и как нужно подключать.

Кстати, монтажной также считается электросхема соединений, которая предназначена для подключения электрооборудования, а также соединения установок между собой в пределах одной цепи. При подключении бытовой техники руководствуются именно монтажной схемой.

Объединенная

Ну и последней из применяемых в распределительных сетях электросхемой является объединенная, которая может включать в себя несколько видов и типов документов. Ее используют в том случае, если можно без сильного нагромождения чертежа обозначить все важные особенности цепи. Используют объединенный проект чаще всего на предприятиях. Домашним мастерам такой тип схемы вряд ли может встретиться. Пример Вы можете увидеть ниже:

Объединенная

Существует также схема кабельных трасс, которая представляет собой упрощенный план прокладки кабельной линии к распределительным пунктам и трансформаторным подстанциям. Ее назначение аналогично монтажной электросхеме – с помощью данного документа монтажники руководствуются как вести линию от точки А к точке Б.

Напоследок рекомендуем просмотреть полезное видео по теме:

Вот мы и рассмотрели основные виды и типы электрических схем, а также их назначение и характеристики. Зная условные обозначения и имея под рукой всю нужную документацию совсем не сложно разобраться в том, как работает та или иная установка.

Будет интересно прочитать:

samelectrik.ru

Как создавать понятные логические (L3) схемы сети / Habr

Cамая большая проблема, с которой я сталкиваюсь при работе с сетями предприятий — это отсутствие чётких и понятных логических схем сети. В большинстве случаев я сталкиваюсь с ситуациями, когда заказчик не может предоставить никаких логических схем или диаграмм. Сетевые диаграммы (далее L3-схемы) являются чрезвычайно важными при решении проблем, либо планировании изменений в сети предприятия. Логические схемы во многих случаях оказываются более ценными, чем схемы физических соединений. Иногда мне встречаются «логически-физически-гибридные» схемы, которые практически бесполезны. Если вы не знаете логическую топологию вашей сети, вы слепы. Как правило, умение изображать логическую схему сети не является общим навыком. Именно по этой причине я пишу эту статью про создание чётких и понятных логических схем сети.

Какая информация должна быть представлена на L3-схемах?

Для того, чтобы создать схему сети, вы должны иметь точное представление о том, какая информация должна присутствовать и на каких именно схемах. В противном случае вы станете смешивать информацию и в итоге получится очередная бесполезная «гибридная» схема. Хорошие L3-схемы содержат следующую информацию:
  • подсети
    • VLAN ID (все)
    • названия VLAN’ов
    • сетевые адреса и маски (префиксы)

  • L3-устройства
    • маршрутизаторы, межсетевые экраны (далее МСЭ) и VPN-шлюзы (как минимум)
    • наиболее значимые серверы (например, DNS и пр.)
    • ip-адреса этих серверов
    • логические интерфейсы

  • информацию протоколов маршрутизации

Какой информации НЕ должно быть на L3-схемах?

Перечисленной ниже информации не должно быть на сетевых схемах, т.к. она относится к другим уровням [модели OSI, прим. пер.] и, соответственно, должна быть отражена на других схемах:
  • вся информация L2 и L1 (в общем случае)
  • L2-коммутаторы (может быть представлен только интерфейс управления)
  • физические соединения между устройствами

Используемые обозначения

Как правило, на логических схемах используются логические символы. Большинство из них не требуют пояснений, но т.к. я уже видел ошибки их применения, то позволю себе остановиться и привести несколько примеров:
  • Подсеть, представленная как трубка или линия:

  • VRF или другая не известная точно зона представляется в виде облака:


Какая информация необходима для создания L3-схемы?

Для того, чтобы создать логическую схему сети, понадобится следующая информация:
  • Схема L2 (или L1) — представление физических соединений между устройствами L3 и коммутаторами
  • Конфигурации устройств L3 — текстовые файлы либо доступ к GUI, и т.д.
  • Конфигурации устройств L2 — текстовые файлы либо доступ к GUI, и т.д.
Пример

В данном примере мы будем использовать простую сеть. В ней будут присутствовать коммутаторы Cisco и МСЭ Juniper Netscreen. Нам предоставлена схема L2, также как и конфигурационные файлы большинства представленных устройств. Конфигурационные файлы пограничных маршрутизаторов ISP не предоставлены, т.к. в реальной жизни такую информацию ISP не передаёт. Ниже представлена L2-топология сети:

А здесь представлены файлы конфигурации устройств. Оставлена только необходимая информация:

asw1

!
vlan 210
name Servers1
!
vlan 220
name Servers2
!
vlan 230
name Servers3
!
vlan 240
name Servers4
!
vlan 250
name In-mgmt
!
interface GigabitEthernet0/1
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface GigabitEthernet0/2
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface vlan 250
ip address 192.168.10.11 255.255.255.128
!
ip default-gateway 192.168.10.1


asw2

!
vlan 210
name Servers1
!
vlan 220
name Servers2
!
vlan 230
name Servers3
!
vlan 240
name Servers4
!
vlan 250
name In-mgmt
!
interface GigabitEthernet0/1
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface GigabitEthernet0/2
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface vlan 250
ip address 192.168.10.12 255.255.255.128
!
ip default-gateway 192.168.10.1


asw3

!
vlan 210
name Servers1
!
vlan 220
name Servers2
!
vlan 230
name Servers3
!
vlan 240
name Servers4
!
vlan 250
name In-mgmt
!
interface GigabitEthernet0/1
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface GigabitEthernet0/2
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface vlan 250
ip address 192.168.10.13 255.255.255.128
!
ip default-gateway 192.168.10.1


csw1

!
vlan 200
name in-transit
!
vlan 210
name Servers1
!
vlan 220
name Servers2
!
vlan 230
name Servers3
!
vlan 240
name Servers4
!
vlan 250
name In-mgmt
!
interface GigabitEthernet0/1
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface GigabitEthernet0/2
switchport mode trunk
switchport trunk encapsulation dot1q
channel-group 1 mode active
!
interface GigabitEthernet0/3
switchport mode trunk
switchport trunk encapsulation dot1q
channel-group 1 mode active
!
interface GigabitEthernet0/4
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface GigabitEthernet0/5
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface GigabitEthernet0/6
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface Port-channel 1
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface vlan 200
ip address 10.0.0.29 255.255.255.240
standby 1 ip 10.0.0.28
!
interface vlan 210
ip address 192.168.0.2 255.255.255.128
standby 2 ip 192.168.0.1
!
interface vlan 220
ip address 192.168.0.130 255.255.255.128
standby 3 ip 192.168.0.129
!
interface vlan 230
ip address 192.168.1.2 255.255.255.128
standby 4 ip 192.168.1.1
!
interface vlan 240
ip address 192.168.1.130 255.255.255.128
standby 5 ip 192.168.1.129
!
interface vlan 250
ip address 192.168.10.2 255.255.255.128
standby 6 ip 192.168.10.1
!
ip route 0.0.0.0 0.0.0.0 10.0.0.17


csw2

!
vlan 200
name in-transit
!
vlan 210
name Servers1
!
vlan 220
name Servers2
!
vlan 230
name Servers3
!
vlan 240
name Servers4
!
vlan 250
name In-mgmt
!
interface GigabitEthernet0/1
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface GigabitEthernet0/2
switchport mode trunk
switchport trunk encapsulation dot1q
channel-group 1 mode active
!
interface GigabitEthernet0/3
switchport mode trunk
switchport trunk encapsulation dot1q
channel-group 1 mode active
!
interface GigabitEthernet0/4
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface GigabitEthernet0/5
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface GigabitEthernet0/6
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface Port-channel 1
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface vlan 200
ip address 10.0.0.30 255.255.255.240
standby 1 ip 10.0.0.28
!
interface vlan 210
ip address 192.168.0.3 255.255.255.128
standby 2 ip 192.168.0.1
!
interface vlan 220
ip address 192.168.0.131 255.255.255.128
standby 3 ip 192.168.0.129
!
interface vlan 230
ip address 192.168.1.3 255.255.255.128
standby 4 ip 192.168.1.1
!
interface vlan 240
ip address 192.168.1.131 255.255.255.128
standby 5 ip 192.168.1.129
!
interface vlan 250
ip address 192.168.10.3 255.255.255.128
standby 6 ip 192.168.10.1
!
ip route 0.0.0.0 0.0.0.0 10.0.0.17


fw1

set interface ethernet0/1 zone untrust
set interface ethernet0/1.101 tag 101 zone dmz
set interface ethernet0/1.102 tag 102 zone mgmt
set interface ethernet0/2 zone trust
set interface ethernet0/1 ip 10.0.0.1/28
set interface ethernet0/1 manage-ip 10.0.0.2
set interface ethernet0/1.101 ip 10.0.0.33/28
set interface ethernet0/1.102 ip 10.0.0.49/28
set interface ethernet0/2 ip 10.0.0.17/28
set interface ethernet0/2 manage-ip 10.0.0.18
set vrouter trust-vr route 0.0.0.0/0 interface ethernet0/1 gateway 10.0.0.12


fw2

set interface ethernet0/1 zone untrust
set interface ethernet0/1.101 tag 101 zone dmz
set interface ethernet0/1.102 tag 102 zone mgmt
set interface ethernet0/2 zone trust
set interface ethernet0/1 ip 10.0.0.1/28
set interface ethernet0/1 manage-ip 10.0.0.3
set interface ethernet0/1.101 ip 10.0.0.33/28
set interface ethernet0/1.102 ip 10.0.0.49/28
set interface ethernet0/2 ip 10.0.0.17/28
set interface ethernet0/2 manage-ip 10.0.0.19
set vrouter trust-vr route 0.0.0.0/0 interface ethernet0/1 gateway 10.0.0.12


outsw1

!
vlan 100
name Outside
!
vlan 101
name DMZ
!
vlan 102
name Mgmt
!
interface GigabitEthernet1/0
description To-Inet-rtr1
switchport mode access
switchport access vlan 100
!
interface GigabitEthernet1/1
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface GigabitEthernet1/3
switchport mode trunk
switchport trunk encapsulation dot1q
channel-group 1 mode active
!
interface GigabitEthernet1/4
switchport mode trunk
switchport trunk encapsulation dot1q
channel-group 1 mode active
!
interface Port-channel 1
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface vlan 102
ip address 10.0.0.50 255.255.255.240
!
ip default-gateway 10.0.0.49


outsw2

!
vlan 100
name Outside
!
vlan 101
name DMZ
!
vlan 102
name Mgmt
!
interface GigabitEthernet1/0
description To-Inet-rtr2
switchport mode access
switchport access vlan 100
!
interface GigabitEthernet1/1
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface GigabitEthernet1/3
switchport mode trunk
switchport trunk encapsulation dot1q
channel-group 1 mode active
!
interface GigabitEthernet1/4
switchport mode trunk
switchport trunk encapsulation dot1q
channel-group 1 mode active
!
interface Port-channel 1
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface vlan 102
ip address 10.0.0.51 255.255.255.240
!
ip default-gateway 10.0.0.49

Сбор информации и её визуализация

Хорошо. Теперь, когда мы имеем всю необходимую информацию, можно приступать к визуализации.
Процесс отображения шаг за шагом

  1. Сбор информации:
    1. Для начала откроем файл конфигурации (в данном случае ASW1).
    2. Возьмём оттуда каждый ip-адрес из разделов интерфейсов. В данном случае есть только один адрес (192.168.10.11) с маской 255.255.255.128. Имя интерфейса — vlan250, и имя vlan 250 — In-mgmt.
    3. Возьмём все статические маршруты из конгфигурации. В данном случае есть только один (ip default-gateway), и он указывает на 192.168.10.1.

  2. Отображение:
    1. Теперь давайте отобразим информацию, которую мы собрали. Во-первых, нарисуем устройство ASW1. ASW1 является коммутатором, поэтому используем символ коммутатора.
    2. Нарисуем подсеть (трубку). Назначим ей имя In-mgmt, VLAN-ID 250 и адрес 192.168.10.0/25.
    3. Соединим ASW1 и подсеть.
    4. Вставляем текстовое поле между символами ASW1 и подсети. Отобразим в нём имя логического интерфейса и ip-адрес. В данном случае имя интерфейса будет vlan250, и последний октет ip-адреса — .11 (это является общей практикой — отображать только последний октет ip-адреса, т.к. ip-адрес сети уже присутствует на схеме).
    5. Также в сети In-mgmt есть другое устройство. Или, как минимум, должно быть. Нам ещё неизвестно имя этого устройства, но его IP-адрес 192.168.10.1. Мы узнали это потому, что ASW1 указывает на этот адрес как на шлюз по-умолчанию. Поэтому давайте отобразим это устройство на схеме и дадим ему временное имя «??». Также добавим его адрес на схему — .1 (кстати, я всегда выделяю неточную/неизвестную информацию красным цветом, чтобы глядя на схему можно было сразу понять, что на ней требует уточнения).


На этом этапе мы получаем схему, подобную этой:

Повторите этот процесс шаг за шагом для каждого сетевого устройства. Соберите всю информацию, относящуюся к IP, и отобразите на этой же схеме: каждый ip-адрес, каждый интерфейс и каждый статический маршрут. В процессе ваша схема станет очень точной. Убедитесь, что устройства, которые упомянуты, но пока неизвестны, отображены на схеме. Точно так же, как мы делали ранее с адресом 192.168.10.1. Как только вы выполните всё перечисленное для всех известных сетевых устройств, можно начать выяснение неизвестной информации. Вы можете использовать для этого таблицы MAC и ARP (интересно, стоит ли писать следующий пост, рассказывающий подробно об этом этапе?).

В конечном счёте мы будем иметь схему наподобие этой:

Заключение

Нарисовать логическую схему сети можно очень просто, если вы обладаете соответствующими знаниями. Это продолжительный процесс, выполняемый вручную, но это отнюдь не волшебство. Как только у вас есть L3-схема сети, достаточно нетрудно поддерживать её в актуальном состоянии. Получаемые преимущества стоят приложенных усилий:
  • вы можете планировать изменения быстро и точно;
  • решение проблем занимает гораздо меньше времени, чем до этого. Представим, что кому-то нужно решить проблему недоступности сервиса для 192.168.0.200 до 192.168.1.200. После просмотра L3-схемы можно с уверенностью сказать, что МСЭ не является причиной данной проблемы.
  • Вы можете легко соблюдать корректность правил МСЭ. Я видел ситуации, когда МСЭ содержали правила для трафика, который никогда бы не прошёл через этот МСЭ. Этот пример отлично показывает, что логическая топология сети неизвестна.
  • Обычно как только L3-схема сети создана, вы сразу заметите, какие участки сети не имеют избыточности и т.д. Другими словами, топология L3 (а также избыточность) является такой же важной как избыточность на физическом уровне.

habr.com

Отправить ответ

avatar
  Подписаться  
Уведомление о